How to deal with ACMEv1 is deprecated and you can no longer get certificates from this endpoint. Please use the ACMEv2 endpoint

Whilst trying to renew a Let’s Encrypt certificate on an older CentOS server, you might experience the following:

Cert is due for renewal, auto-renewing...
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Attempting to renew cert from /etc/letsencrypt/renewal/mail.blue-hat.co.za.conf produced an unexpected error: urn:acme:error:serverInternal :: The server experienced an internal error :: ACMEv1 is deprecated and you can no longer get certificates from this endpoint. Please use the ACMEv2 endpoint, you may need to update your ACME client software to do so. Visit https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430/27 for more information.. Skipping.

The problem is certbot is outdated. Do this:

yum update certbot

Reference

Upgrade a Single Package on CentOS/Fedora

yum update certbot

Share this article

Leave a Reply

Your email address will not be published.

Scroll to Top