At times Outlook might start looping for power users. The messages received is:
> The message store has reached its maximum size. To reduce the amount of data in this file, permanently delete some items that you no longer need.
Outlook then stops working. No matter what action is taken, Outlook just loops over and over with the same error message. Some system folders are accessible, e.g. deleted items and spam, but even so, deleting items in these folders do not work. The message just repeats itself.
Cause
The user has reached the hard limit of the Outlook client which is 50 gigabytes. It’s possible to increase the limit, but bear in mind why limits are there. Limits are there because it becomes unwieldy to manage files of inordinate sizes. For example, it’s not entirely trivial to backup or restore on massive 50 GB file.
But anyhow, since the software is looping and you have no choice, update the limit and then get the user to stop hoarding and start deleting. Another option is to get the user to archive.
How to Fix
Use the registry and set two new keys that might not exist:
regedit \ Computer \ HKEY_CURRENT_USER \ Software \ Microsoft \ Office \ 16.0 \ Outlook \ PST
The PST folder may well not exist. Create it.
Now add these REG_DWORDs:
MaxLargeFileSize
REG_DWORD
Value: 92160 (Decimal)
WarnLargeFileSize
REG_DWORD
Value: 92160 (Decimal)
Screenshot, it should look like this when you’re done:
Question
Does this also work with Microsoft Outlook 365?
Answer
Yes it does. The “16” has no relevance.