How to deal with “The message store has reached its maximum size. To reduce the amount of data in this file, permanently delete some items that you no longer need.” looping

Background

At times Outlook might start looping for power users. The messages received is:

> The message store has reached its maximum size. To reduce the amount of data in this file, permanently delete some items that you no longer need.

Outlook then stops working. No matter what action is taken, Outlook just loops over and over with the same error message. Some system folders are accessible, e.g. deleted items and spam, but even so, deleting items in these folders do not work. The message just repeats itself.

Cause

The user has reached the hard limit of the Outlook client which is 20 gigabytes (version 2007) and 50 gigabytes (newer version). It’s possible to increase the limit, but bear in mind why limits are there. Limits are there because it becomes unwieldy to manage files of inordinate sizes. For example, it’s not entirely trivial to backup or restore on massive 50 GB file. You might want to ask yourself why the user has never archived, or perhaps why you are storing so much important information without cleaning up.

But anyhow, since the software is looping and you have no choice, update the limit and then get the user to stop hoarding and start deleting. Another option is to get the user to archive.

How to Fix

Use the registry and set two new keys that might not exist:

regedit \ Computer \ HKEY_CURRENT_USER \ Software \ Microsoft \ Office \ 16.0 \ Outlook \ PST

If you’re using Outlook 2013, don’t use 16.0 as per above, but rather 15.

The PST folder also may well not exist. Please create it.

Now add these REG_DWORDs:

MaxLargeFileSize
Decimal Value: 92160

WarnLargeFileSize
Decimal Value: 92160

Here is a screenshot, this is what it should look like when you’re done. Remember to use 15.0 if you have Outlook 2013:

Question about “16.0”

Does this also work with Microsoft Outlook 365?

Answer

Yes it does. The “16” has relevance to that version.

  • Outlook Office365, 2019, 2016: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\PST
  • Outlook 2013: HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\PST
  • Outlook 2010: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\PST
  • Outlook 2007: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\PST
  • Outlook 2003: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\PST

Reference

Share this article

Leave a Reply

Your email address will not be published. Required fields are marked *

Scroll to Top